Uploaded image for project: 'IoTivity'
  1. IoTivity
  2. IOT-599

IoTivity needs to support "make install" equivalent

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: P1
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Build System
    • Labels:
      None
    • Found in Version/s:
      0.9.1
    • Operating System:
      Ubuntu
    • Issue Severity:
      Major
    • Reproducibility:
      Always (100%)

      Description

      IoTivity needs to support getting installed. That implies:

      • copy the public libraries to ${libdir} (and only those)
      • copy the public headers to ${includedir} (and only those, not private headers)

      This is required for 1.0.

        Attachments

          Issue Links

          No reviews matched the request. Check your Options in the drop-down menu of this sections header.

            Activity

              People

              • Assignee:
                nravi Ravi Nanjundappa
                Reporter:
                thiago Thiago Macieira
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: